OpenAM OpenJDK 8 非互換問題 [AM20201118-1]

Red Hat Enterprise Linux にて提供される java-1.8.0-openjdk において、XML Security ライブラリに変更が行われました。これに伴い、OpenAM の一部の機能が正常に動作しないことを確認しております。

2020-11-18

サポートニュース

OpenAM

update

不具合情報

Red Hat Enterprise Linux にて提供される java-1.8.0-openjdk において、XML Security ライブラリに変更が行われました。これに伴い、OpenAM の一部の機能が正常に動作しないことを確認しております。

対象

  • OpenAM 11.0.0
    • osstech-openam11-11.0.0-129 以前のバージョン

※ OpenAM 9.5.5、13.0.0、14.0.0 は対象外です。

非互換の詳細

OpenJDK 8u272 より XML Security ライブラリの関数が変更されました。 このため、XML Security ライブラリを利用する処理において AbstractMethodError エラーが発生します。

この問題により SAML が正常に動作しなくなることを確認しております。

暫定回避策

java-1.8.0-openjdk-1.8.0.272 以降へのパッケージアップデートを行わないでください。 アップデートを行ってしまった場合は、以下の手順で正常に動作するバージョンへダウングレードを行って下さい。

RHEL7 (CentOS7)

  • 正常に動作するリリースバージョン
    • java-1.8.0-openjdk-1.8.0.262.b10-1.el7

yumのコマンド例

# yum downgrade  
 java-1.8.0-openjdk-1.8.0.262.b10-1.el7  
 java-1.8.0-openjdk-headless-1.8.0.262.b10-1.el7  

rpmのコマンド例

# rpm -Uvh --oldpackage  
 java-1.8.0-openjdk-1.8.0.262.b10-1.el7.x86_64.rpm  
 java-1.8.0-openjdk-headless-1.8.0.262.b10-1.el7.x86_64.rpm  

RHEL6 (CentOS6)

  • 正常に動作するリリースバージョン
    • java-1.8.0-openjdk-1.8.0.265.b01-0.el6_10

yum のコマンド例

# yum downgrade  
 java-1.8.0-openjdk-1.8.0.265.b01-0.el6_10  
 java-1.8.0-openjdk-headless-1.8.0.265.b01-0.el6_10  

rpm のコマンド例

# rpm -Uvh --oldpackage  
 java-1.8.0-openjdk-1.8.0.265.b01-0.el6_10.x86_64.rpm  
 java-1.8.0-openjdk-headless-1.8.0.265.b01-0.el6_10.x86_64.rpm  

恒久対策

java-1.8.0-openjdk-1.8.0.272 に対応した OpenAMパッケージをリリース予定です。 パッケージがリリースされましたら、OpenAM パッケージと java-1.8.0-openjdk パッケージのアップデートをお願いいたします

Go To Top